1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

Problem with MD 35mm

Discussion in 'Adapted Lenses' started by NickCyprus, Jul 6, 2013.

  1. NickCyprus

    NickCyprus Super Moderator

    Oct 11, 2012
    Cyprus
    Nick
    I recently bought an MD 35 f/2.8. I tested it as soon as it arrived and everything was fine (optically, mechanically). If there was something I could report was just that the aperture ring didn't have that positive click into place but it didn't seem to affect anything.

    I mounted it on an adapter and noticed that it was a bit stiff to lock into place. After a few days, the aperture ring doesn't work anymore :( Its stuck at the widest setting and doesn't move. At first I thought it was a problem with the adapter so I tried all my other adapters but still the same (all from the same seller and all work great on all my other MD lenses)

    Any ideas?
     
  2. Jaf-Photo

    Jaf-Photo TalkEmount Veteran

    484
    Mar 25, 2013
    There is a tiny steel ball inside the aperture ring which clicks into tiny grooves in the barrel. Try opening the lens from the back carefully and remove the aperture ring see what is up with the ball. Most likely it has been dislodged. Place the camera on a large, flat and dark surface so you'll see the ball if it falls off.
     
  3. Amamba

    Amamba TalkEmount All-Pro

    Apr 13, 2013
    SE MI
    I had the same problem on one of the two 50/1.7 I have. Found that the small spring loaded steel tube that pushed this ball against the barrel was deformed. Unfortunately I only found this when it got so bad I had to pull it out & throw away to make lens work. It still operates fine, but has no positive stops on aperture setting, just rotates freely.
     
  4. NickCyprus

    NickCyprus Super Moderator

    Oct 11, 2012
    Cyprus
    Nick
    Thanks Amamba :)

    I've arragned to take it to a pro to take a look at its since I'm scared to open it up myself. Hopefully its not an expensive fix/charge...

    What I don't understand is how it worked perfectly fine when I received it (seller advertised it as "mint" and it was) and all of the sudden (as soon I mounted it on the adapter) the aperture ring stucked :?
     
  5. NickCyprus

    NickCyprus Super Moderator

    Oct 11, 2012
    Cyprus
    Nick
    Update:
    I spoke on the phone with the guy who's repairing the lens for me, and he confirmed that the problem is probably at the "ball" (as Jaf and Amamba advised). I scedualed to take it for repair on Friday. He said that its an easy fix and won't charge much (20euro)!!!

    So, on Saturday I can hopefully finally try the MD 35mm :D
     
  6. NickCyprus

    NickCyprus Super Moderator

    Oct 11, 2012
    Cyprus
    Nick
    Got the repaired lens back today. Works great!!!
    The guy who repaired it told me that after he closely examined the lens internally he can report that its pristine and that it must not have been used at all. Only charged 20euro and on top of that he cleaned my MD 135 f/3.5 for free!!!
     
  7. davect01

    davect01 Super Moderator

    Aug 20, 2011
    Fountain Hills, AZ
    Dave
    Not bad. Now you gotta shot something.
     
  8. Bimjo

    Bimjo Super Moderator

    Oct 28, 2011
    Washington State
    Jim
    Can't beat a deal like that Nick. ;)
     
  9. addieleman

    addieleman Passionate amateur

    Nov 13, 2012
    Netherlands
    Ad Dieleman
    That's great Nick, let us know how you like it!