1. Reminder: Please use our affiliate links for holiday shopping!

NEX-7 no longer works with SD card in it

Discussion in 'Sony Alpha E-Mount Cameras' started by Poki, Nov 14, 2014.

  1. Poki

    Poki TalkEmount Hall of Famer

    Aug 30, 2011
    Austria
    I have a strange problem today. Until now, my NEX-7 worked perfectly fine. But now, when I turn it on, I can't do anything. It shows the scene as usual, but none of the buttons do anything - it doesn't even show the buttons on-screen at the right like it usually does. However, I can manually focus E-mount lenses as always.

    After trying different setups with many lenses, batteries and SD cards, I know what causes the problem - the SD cards. When I turn it on without an SD card in it, everything is fine. But as soon as I put an SD card in, it doesn't work. But obviously, I need to put an SD card in.

    So what could cause this? Any ideas?

    Edit:
    When I turn it off and back on with an SD card in it it does one of the two things: Just turning the screen off and back on or turning the camera off, but when turning it on again it just shows a black screen.
     
  2. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    David
    Hm. Since you've tried different SD cards, it would seem that sending the camera in for repair is your only option. Bummer. :(
     
    • Like Like x 1
  3. Poki

    Poki TalkEmount Hall of Famer

    Aug 30, 2011
    Austria
    Yeah, tried five different cards which all work in my NEX-5 ...

    Damn, that thing worked perfect yesterday, and all it did since then is sitting on its shelf. :(

    But to me, it seems like a firmware problem - after all, the camera works without an SD card in it. So I'll first try resetting the firmware, hopefully that helps ...
     
  4. José De Bardi

    José De Bardi Assistant in Virtue

    Aug 31, 2013
    Dorset, UK
    José
    Maybe try a sony memory stick too?
     
  5. Poki

    Poki TalkEmount Hall of Famer

    Aug 30, 2011
    Austria
    I don't own any memory sticks anymore, and I never again want to deal with them ...

    But, after fiddling around with the camera for two hours, I left it alone to eat something. When I came back, it worked ... I really don't know what caused this, and now I severely doubt the reliability of my NEX-7. Hope this doesn't happen again, though.

    Btw., the Sony Firmware Updater still doesn't find the camera. Not that I need any of the features included in 1.03, but still, not the best piece of software.
     
  6. NickCyprus

    NickCyprus Super Moderator

    Oct 11, 2012
    Cyprus
    Nick
    I can't help of what might have caused this but bummer indeed :(

    I also felt frustrated and in doubt about the reliability of my nex-6 when I faced the "no lens attached", blackened screen issue - my tech solved it and I haven't faced the problen since.

    I'd also consider sending in for repair too...I know how much you love your nex-7
     
  7. Poki

    Poki TalkEmount Hall of Famer

    Aug 30, 2011
    Austria
    Oh yeah, I do. :D

    But I won't send it anywhere until I absolutely have to. Living a whole weekend without my NEX-7? That thought hurts a bit.
     
  8. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    David
    Now THAT'S the understatement of the week! ;)

    Sony does many things well, but software and firmware aren't among them. From their execrable menu systems on early NEX cameras to the latest snafu of releasing a firmware update for the A7/R/S cameras that doesn't work with the current MacOS, their software team seems to live in a bubble wrapped in a lead shield.

    It's good news to hear that your NEX-7 suddenly (and inexplicably) regained consciousness, but I wouldn't trust it not to go back into a coma at the most inopportune moment. If it were mine, I'd have it boxed up and on its way to Sony repair already.
     
    • Like Like x 1
  9. Poki

    Poki TalkEmount Hall of Famer

    Aug 30, 2011
    Austria
    Wasn't there an update that bricked the PS4 too? Still, they're not alone. iOS 8 made my iPhone 5 practically unusable (until 8.1 arrived - 8.0.2 only made things worse) and the 50mm Touit even got shipped with a defect firmware (still didn't come around to send it in to let Zeiss update the firmware ...). Nowadays, quality control seems to be not a priority when it comes to software.

    For this reason, I always pack my NEX-5 too. It weighs pretty much nothing anyway, and it NEVER let me down in the four and a half years I own it. Sure, no EVF, a previous gen sensor and almost no control buttons and wheels, but it gives me a safe enough feeling to keep using the 7 right now. If it has any hickups in the coming weeks I'll have to send it to Sony anyway.
     
  10. davect01

    davect01 Super Moderator

    Aug 20, 2011
    Fountain Hills, AZ
    Dave
    Lame, lame lame.

    Sounds like you have done everything I would know of to fix this.

    Best of luck.
     
  11. NickCyprus

    NickCyprus Super Moderator

    Oct 11, 2012
    Cyprus
    Nick
  12. SpaceManSpiff

    SpaceManSpiff TalkEmount Top Veteran

    547
    Dec 13, 2013
    Tucson, AZ
    Eric
    Oh that really sucks. Is there a way to "re-boot" the camera? :coffee:
     
  13. rdfisch

    rdfisch TalkEmount Regular

    181
    Nov 13, 2013
    Northern NJ
    Rick
    Already mentioned in the link Nick provided, but have you blown some compressed air in the SD slot ?

    Glad to hear it's working again, but still worth doing in case there's anything kicking around in there.
     
  14. Poki

    Poki TalkEmount Hall of Famer

    Aug 30, 2011
    Austria
    Nope, I didn't do anything to the slot, that's the strange thing. But I looked closely in there, and everything looks clean. Maybe some gremlin was in there.
     
  15. Hawkman

    Hawkman TalkEmount Top Veteran

    941
    Sep 10, 2013
    Virginia, USA
    Steve
    I wonder if it might have been a spot of dirt or moisture in/on one of the internal SD contacts causing a shorted data path. As someone mentioned above, a blast of compressed air couldn't hurt... could it?
     
  16. roundball

    roundball TalkEmount Hall of Famer

    Oct 8, 2013
    USA
    It would be interesting to check with Sony Support and see if they'll admit it's any sort of known problem that's been reported in the past.
     
  17. OldNoob

    OldNoob TalkEmount Veteran

    223
    Oct 30, 2014
    Hi Poki
    Im really sorry about that happened to your camera.
    It kinda reminds me of what a few of us Pentax owners experienced once. Quite a few k-30 owners reports problems similar to yours. Turns out that in many cases the battery voltage had become off by just a bit, possibly due to dyeing cells within the battery causing a "Voltage overcharge" issue and possibly discharge rate or (mA) were incorrect even though the battery displayed as fully charged. It caused a mered of problems from locked cameras to "No Card Read" errors.
    Hope that helps.
    By the way, Do you know the Activation count and record hours on your camera?