1. Reminder: Please use our affiliate links for holiday shopping!

Nex 6 with Sony DT 16-50 2,8 SSM?

Discussion in 'Adapted Lenses' started by ChristerB, Sep 3, 2013.

  1. ChristerB

    ChristerB TalkEmount Rookie

    21
    Sep 2, 2013
    Stockholm Sweden
    Christer Brandt
    Hello! My first post here :)

    I have a Nex 6 laying in the postoffice waiting for me (my first Nex btw) with it comes the 16-50mm OSS and the E 20mm 2,8 at home I have the Sony LA-EA1 adapter. Has anyone here tried that adapter on the Nex 6 with the DT 16-50 2,8 SSM? I´m thinking of getting that lens instedad of the zoom that comes with the camera, does the Sony SSM and SAM lenses works as if on an Alpha camrea on the adapter or do I loose something, speed, AF, light?
    At the moment I have the a700 and a77 with a lot of lenses but now I plan on selling of a lot of stuff and focusing on lenses that works well on both A- and E-mount.

    Cheers / Christer
     
  2. Bimjo

    Bimjo Super Moderator

    Oct 28, 2011
    Washington State
    Jim
    Welcome to the NEX and the forum. :)

    Someone else will have to help with your EA-1 questions, though I do know the EA-2 has better AF speed than the EA-1.
     
  3. ChristerB

    ChristerB TalkEmount Rookie

    21
    Sep 2, 2013
    Stockholm Sweden
    Christer Brandt
    Thank you x 2 ;-) I've tried it with the Sony 30 mm 2,8 Marco SAM but it will not autofocus? I have some reading to to!
     
  4. Bimjo

    Bimjo Super Moderator

    Oct 28, 2011
    Washington State
    Jim
    I believe the EA-1 requires a focus motor in the lens where the EA-2 will focus screw drive lenses. Does the SAL30 macro have a screw drive?
     
  5. ChristerB

    ChristerB TalkEmount Rookie

    21
    Sep 2, 2013
    Stockholm Sweden
    Christer Brandt
    No it has the SAM motordrive, I get a "reaction" when I stick it on but no more than that, I got a "reaction" with the Sigma 50 mm 1,4 DG HSM as well but no more than that.....
     
  6. ChristerB

    ChristerB TalkEmount Rookie

    21
    Sep 2, 2013
    Stockholm Sweden
    Christer Brandt
    Maybe I need to upgrade the software as it is "ver. 1.01" and "lens mount adapter ver. 01"?
     
  7. ChristerB

    ChristerB TalkEmount Rookie

    21
    Sep 2, 2013
    Stockholm Sweden
    Christer Brandt
    Nope! New firmware was not the problem!
     
  8. Bimjo

    Bimjo Super Moderator

    Oct 28, 2011
    Washington State
    Jim
    Sorry, I've exhausted my meager Sony adapter knowledge. :(
     
  9. ChristerB

    ChristerB TalkEmount Rookie

    21
    Sep 2, 2013
    Stockholm Sweden
    Christer Brandt
    I have found the solution, I have to upgrade the firmware in the adapter as well and then I will be up and running! :)
     
  10. Bimjo

    Bimjo Super Moderator

    Oct 28, 2011
    Washington State
    Jim
    Rock on! :2thumbs:
     
  11. ChristerB

    ChristerB TalkEmount Rookie

    21
    Sep 2, 2013
    Stockholm Sweden
    Christer Brandt
    One can wonder what Sonys thinking about sometimes! The update is not avalible if you have a Nex 6! Grrrrr I need an Nex 3 or 5 to run the update through, will visit a shop next week and see if they can help me out!