1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

New A7 Update Out !!

Discussion in 'Sony Alpha E-Mount Cameras' started by sonicbuffalo, Oct 30, 2014.

  1. sonicbuffalo

    sonicbuffalo TalkEmount Regular

    68
    Aug 7, 2014
    North Carolina
    Chris
    I just updated the software for mine today. It is version 1.10 or something like that. Read on Sony's website for a description of what this update will do for you. It's approximately 136 mb's.

    click here
     
    • Like Like x 3
  2. LoFi

    LoFi TalkEmount Regular

    101
    Nov 16, 2013
    Eliot
    What's it do?
     
  3. robfactory

    robfactory TalkEmount Regular

    124
    Aug 23, 2014
    Rob
    I noticed my camera turning on almost instantly.
     
    • Like Like x 1
  4. christilou

    christilou TalkEmount Veteran

    415
    Nov 26, 2012
    Surrey, UK
    Christina
    Do we need to hook up the usb cable or can I save the file direct to the card and do it that way? I've never updated a Sony before.
     
    • Like Like x 1
  5. eno789

    eno789 TalkEmount Top Veteran

    720
    Jan 1, 2012
    NoCal, USA
    Brian
    In the case of Sony E mount cameras, you'll need to hook up the usb cable.
     
    • Like Like x 2
  6. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    David
    Has anyone had any luck updating their A7 on MacOS 10.10 (Yosemite)? It hasn't worked for me so far. These are are the steps I've tried:

    1. I've downloaded the patch a second time from the Sony site, making extra sure that I got the correct one for the A7 in the U.S.
    2. I've taken out the camera's battery to reset everything (and then put it back in). It's fully charged.
    3. I've quit all other running apps on the Mac.
    4. I've tried two different USB cables.
    5. I've verified that the camera is in "Mass Storage" mode.
    6. I've even tried running in "Safe Mode."

    The update starts just fine, but all I get is a spinning progress indicator followed by an error message telling to take the battery out and then put it back and try again.

    I've read that some Windows users running current versions of their OS have sometimes run into trouble using Sony firmware updates because Sony seems to run a little behind the technology curve. So I wonder if the recently released MacOS 10.10 might be a little too advanced for Sony's firmware.

    I guess I should be grateful that the unresponsive update hasn't bricked my camera.

    But if any other Yosemite users have any luck with this update, I'd sure like to hear about it.

    EDIT: I've just read over on DPReview that the Sony update is indeed incompatible with Apple's latest OS. Well, now I know. :(
     
  7. mrlrz

    mrlrz TalkEmount Regular

    65
    Nov 13, 2013
    A lot of people complain about different misbehaviors of Sony updates on Mac OS X, not just Yosemite but Mavericks too.
    I've ended using a win 7 machine from the office
     
  8. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    David
    Yes, I've read some of those too. But I've never had any trouble doing two Sony camera, and multiple Sony lens updates on my Macs. Ah well, maybe Sony will get this fixed by the time MacOS 10.11 (Oxnard) rolls out. :p
     
  9. hodad66

    hodad66 Sony Guru

    582
    Feb 8, 2012
    Indialantic, Fl
    John
    I'm glad that I saw this as my A7R starts up much faster now!!
     
  10. Vincepad

    Vincepad TalkEmount Regular

    165
    Dec 29, 2013
    No love on either of two Macs, both running Yosemite. I had a problem updating an NEX-6 about a year ago on the same Macs. It ended up getting bricked. I sent it in to Sony, and they repaired it and returned it in about a week. But yeah, striking out with the a7 on Yosemite. I'm trying to revive an old windows box to do the update.
     
  11. TareqPhoto

    TareqPhoto TalkEmount Regular

    57
    Jun 16, 2014
    Tareq
    Yes, i have Mac OS X 10.9.x [Maverick] and it didn't work, but i have too many computers that nothing can stop me from one computer problem, so i did update from PC using Windows 7 64-bit.....Done!!!
     
  12. Vincepad

    Vincepad TalkEmount Regular

    165
    Dec 29, 2013
    Windows 8.1 - no problems. Definitely snappier when I turn it back on. I never did the previous firmware upgrade because of the fear from bricking my NEX-6. Next time, I'll skip even trying it on a Mac, which completely blows. Oh, well. Thanks, Sony.
     
    • Like Like x 1
  13. addieleman

    addieleman Passionate amateur

    Nov 13, 2012
    Netherlands
    Ad Dieleman
    Did the update just now on the A7 with a Windows 8.1 machine. Smooth update, but it took ages, well 25 minutes anyway. After updating the camera screen showed "Recovering data..." for half a minute and that worried me somewhat, but in the end it restarted and seems to work OK.

    The start-up time doesn't strike me as much faster but I could live with it before. The improvement when updating to V1.02 was much more significant. As I don't have an FE 70-200/4 (yet) I can't test the Focus Hold function. So far, so good, no real benefits but no harm done either.
     
  14. quezra

    quezra TalkEmount Top Veteran

    916
    Aug 22, 2012
    Yeah, I think some people were upgrading from v1.0 or 1.01 directly. I didn't notice much difference moving from 1.02 to 1.10.
     
  15. hodad66

    hodad66 Sony Guru

    582
    Feb 8, 2012
    Indialantic, Fl
    John
    mine was .01 so big improvement
     
  16. Vincepad

    Vincepad TalkEmount Regular

    165
    Dec 29, 2013
    Same here.
     
  17. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    David
    Update: I "borrowed" my wife's MacBook Air which is still running MacOS 10.9 (Mavericks), and ran the installer from it. Went without a hitch, and my A7 is now updated to v.1.10 (from v.1.02). It took about 15 mins. to install the update, and while the difference is not night and day, the cold startup is now noticeably faster.

    Still too slow, though. :rolleyes:
     
    • Like Like x 1
  18. sdsyver

    sdsyver Here to Learn and Enjoy!

    61
    Apr 22, 2014
    Northern Alberta
    Shawn
    Did an Internet chat with Sony and found out that Yosemite is not compatible with this update. He was going to get them working on it. Used my wife's computer with older OSX on it and it worked fine