Lens adaptors and HSS with Pottix Odin on A7

Discussion in 'Lighting Forum' started by Dan Brisbane, Apr 10, 2015.

  1. Dan Brisbane

    Dan Brisbane TalkEmount Rookie

    17
    Apr 10, 2015
    Brisbane, Australia
    Dan
    Hoping someone can help with what I assume is a question with a rather obvious answer....

    Using HSS (high speed sync) with Current sony lenses seems fine, however as soon as I used an old Olympus (50mm 1.8), all I get is a black image. Not a black band, but the whole screen is black. As suggested by the subject title, I use the phottix odin trigger and receivers for Sony on my Sony A7.

    I'm trying to do some indoor portrait work with a shallow depth of field and hence need the higher shutter speeds.

    I am yet to try other legacy lenses (Minolta, Yashica and Leica), however have simply made the assumption (maybe stupidly) that I will have the same issue.

    Appreciate any help that may be out there
     
  2. Kirkp

    Kirkp TalkEmount Regular

    151
    Nov 2, 2014
    Does your on camera flash work with HSS and the Olympus lens?
     
  3. Dan Brisbane

    Dan Brisbane TalkEmount Rookie

    17
    Apr 10, 2015
    Brisbane, Australia
    Dan
    Hi Kirkp

    Doesn't seem to give me the option of turning HSS on, so I guess the answer is no.

    I should add that I am using the flash on manual.
     
  4. michelb

    michelb TalkEmount Regular

    198
    Oct 27, 2013
    Greater Montreal area in Quebec, Canada
    Michel Brien
  5. Dan Brisbane

    Dan Brisbane TalkEmount Rookie

    17
    Apr 10, 2015
    Brisbane, Australia
    Dan