1. Reminder: Please use our affiliate links for holiday shopping!

LA-EA2 and Tamron lens

Discussion in 'Sony Alpha E-Mount Cameras' started by rcksil, Mar 8, 2013.

  1. rcksil

    rcksil TalkEmount Rookie

    23
    Mar 5, 2013
    Long Beach CA
    Rick
    Well I picked up the LA-EA2 mount adapter. Works perfect on all my Sony lenses. I tried it on my Tamrons and will not Auto Focus. I thought it was supposed to work /auto focus on all lenses that had Alpha Mounting. Guess I was wrong or am I missing something? Still going to have fun with my 70-300g on the Nex.

    Rick
     
  2. Bimjo

    Bimjo Super Moderator

    Oct 28, 2011
    Washington State
    Jim
    Is there a AF/MF switch on the lens itself? My PK mount Tammy 28-75 doesn't, but I know some systems use an on-lens switch. If not, try cleaning the lens contacts and see if that helps.
     
  3. gio

    gio TalkEmount Veteran

    382
    Sep 12, 2012
    Manchester, uk
    all mines work with it
     
  4. rcksil

    rcksil TalkEmount Rookie

    23
    Mar 5, 2013
    Long Beach CA
    Rick
    Not sure if it matters but the Tamron only has 8 contacts while the Sony lenses and the LA-EA2 both have 10 contacts. With the Tamron on the NEX and power off the focus ring turns easy and with the power on the ring is harder to turn. Oh well I just might be stuck getting Sony lenses or look at the contacts and make sure they are 10 there.

    Rick
     
  5. -et-

    -et- TalkEmount Veteran

    205
    Jan 26, 2013
    Southern California
    Tom
    I doubt that having less than 10 contacts is the cause of your problem. I have had no problem using my Minolta Maxxum 135mm lens and my Minolta Maxxum 50mm macro lens with the LA-EA2 on my NEX-6. Both of those lenses have only five (5) contacts.

    I apologize in advance for asking the obvious, but have you tried the Tamron on one of your existing cameras to make sure that it still functions properly on a camera other than the NEX?

    - Tom -
     
  6. rcksil

    rcksil TalkEmount Rookie

    23
    Mar 5, 2013
    Long Beach CA
    Rick
    Yes the Tamron works fine on my A55 and A77. Only 2 lenses so no great loss. I will just keep them with the A55. Probably something simple.
    Thanks
    Rick