Is My NEX Dying? :(

Discussion in 'Open Discussion' started by Aurora, Nov 11, 2013.

  1. Aurora

    Aurora TalkEmount Regular

    A couple weeks back my nex c3 started acting funny. When in auto focus it would get stuck and I'd have to take a couple pics with it stuck until it'd become unstuck. Then that wasn't working so I'd have to turn it off and then it would be back to normal once I'd turn it back on. Now, it's not getting unstuck no matter what I do and now there is no menu option or other options on the screen. Does anyone have an idea to what is going on? Would a good cleaning by a pro help fix the problem?
  2. Deadbear77

    Deadbear77 TalkEmount Hall of Famer

    Sep 14, 2012
    Northeast Ohio
    Real Name:
    Have you done a software update? Have you checked the lens? Which lens are you using?

    Sent from my iPhone using TalkNEX mobile app
    • Like Like x 1
  3. Poki

    Poki TalkEmount Hall of Famer

    Aug 30, 2011
    Does it happen with every lens? Have you installed the latest firmware? If so, sounds like your NEX has some defect, maybe your dealer can repair it?
    • Like Like x 1
  4. Aurora

    Aurora TalkEmount Regular

    I have not done a software update. I'll do that, thanks. I have checked all my lenses, it happens with all three which are all nex lenses.
  5. Aurora

    Aurora TalkEmount Regular

    I have not updated the firmware. I will try that. It happens with all my lenses.
  6. bobbywise

    bobbywise TalkEmount Regular

    Nov 6, 2013
    Nantes, France
    Real Name:
    Robert Wisbey
    Did you manage to sort the issue ?
  7. Aurora

    Aurora TalkEmount Regular

    I think so! It seems that the shutter button might be getting stuck. When the camera gets stuck in auto-focus, I tapped the shutter button a couple times and it eventually releases. I just now figured that it helps to tap the shutter button, so I'll test it out all day tomorrow to see how that helps.
  8. Aurora

    Aurora TalkEmount Regular

    Well... that didn't work after all. I'm going to have to contact sony, I suppose. :(