• Welcome to TalkEmount.com, the best Sony E-mount camera and photography community on the web.
    Click here to join for free and enjoy unlimited photo uploads in our forums.

Hot shoe on NEX-6

rich815

TalkEmount Rookie
Joined
Oct 27, 2012
Messages
13
Searched pretty well here and in Google and am surprised I cannot find an answer. If there's a thread I missed please refer me. I was under the impression with the older style hot shoe on the NEX-6 that standard flashes can be used but trying it that's obviously not the case. Is there a menu setting I'm missing or an adapter needed before one can use standard typical hot-shoe mount flashes with the NEX-6? Thanks much,
 

Frank Teurlings

TalkEmount Regular
Joined
Dec 10, 2012
Messages
182
Location
Netherlands
Searched pretty well here and in Google and am surprised I cannot find an answer. If there's a thread I missed please refer me. I was under the impression with the older style hot shoe on the NEX-6 that standard flashes can be used but trying it that's obviously not the case. Is there a menu setting I'm missing or an adapter needed before one can use standard typical hot-shoe mount flashes with the NEX-6? Thanks much,

I have also asked that question. One told me that I have a Multi-Interface Shoe Adapter Model number ADP-MAA needed.
 

nianys

TalkEmount All-Pro
Joined
Aug 23, 2012
Messages
1,558
Location
France
It IS a standard hotshoe, and I am in fact using a Nikon flash and an Olympus flash on mine, I just do NOT get TTL on either.
 

SRHEdD

TalkEmount Top Veteran
Joined
Nov 25, 2012
Messages
624
Location
Viera, Florida, USA
Real Name
Steve
The contacts on the NEX-6 shoe are all crammed up under the front lip. The ADP-MAA has the same contacts. Any normal PC contact-only flash, like a Vivitar 285HV for example, would slide on normally and only touch the typical large center contact.
 

SRHEdD

TalkEmount Top Veteran
Joined
Nov 25, 2012
Messages
624
Location
Viera, Florida, USA
Real Name
Steve
My HVL-F20AM showed up yesterday. It is elegant in its simplicity. Bonus... it does kick in the wireless mode and fires my larger HVL-F43AM. The process is really easy. I like that the 20 also bounces and has a tele/wide switch. I got mine for $97 shipped on ebay, new in the box. Runs on AAA batteries, but I always seem to have those in the battery drawer. I do a lot of table top product photos in my office. I have a table dedicated to it with a white illustration board cover. White ceilings, a little ambient sunlight from the window in the room, and a small bounce flash works great. The only downside is the head doesn't rotate for verticals. Definitely a great NEX accessory worth the money.
 

nianys

TalkEmount All-Pro
Joined
Aug 23, 2012
Messages
1,558
Location
France
To me any flash that doesn't swivel for vertical shots negates the usefulness of an external unit. I've used the little built-in flash bounced, many times, and for landscape orientation it works *flawlessly*. Since I DO want to make portrait orientation shots though, I've bought an Olympus FL-36 (non R). It's a little finicky about the batteries (seems to run only on freshly charged ones) but when it does work it's great. Size is pretty perfectly matched to the NEX 6, too :) Of course I use it in manual mode, but been doing that for so long I don't even have to think about settings anymore...
 

rich815

TalkEmount Rookie
Joined
Oct 27, 2012
Messages
13
It IS a standard hotshoe, and I am in fact using a Nikon flash and an Olympus flash on mine, I just do NOT get TTL on either.

Hmmm, I mounted a couple of Sunpaks, a Nikon, a Fuji, and a Vivitar. None fire off under any settings.
 

tuwinkk

TalkEmount Rookie
Joined
Dec 26, 2012
Messages
18
Location
Singapore
i'm using my canon 580ex...and yes it's fired...but thinking to buy a small flash to be pair with my NEX6..
any reccomendation?
 

rich815

TalkEmount Rookie
Joined
Oct 27, 2012
Messages
13
Maybe your camera is defective. Everybody else, including me, doesn't seem to have a problem to fire a flash via the hotshoe.

Well this is the conclusion I'm coming to as well I just tried 4 or 5 more flashes in the hot shoe on every single mode I can think of in the camera and none of them fired off the external flash. My old Sony F717 requires you to set "external flash" in a menu setting but I see nothing like that in the NEX-6 menus.

Ah well, call to Sony tomorrow I guess.
 

JoeleZ

New to TalkEmount
Joined
Feb 6, 2013
Messages
3
Well this is the conclusion I'm coming to as well I just tried 4 or 5 more flashes in the hot shoe on every single mode I can think of in the camera and none of them fired off the external flash. My old Sony F717 requires you to set "external flash" in a menu setting but I see nothing like that in the NEX-6 menus.

Ah well, call to Sony tomorrow I guess.

can you told me how the result ? i'm facing something similar. i can't use any of my late flash. there is 3 manual flash non ttl. but everytime i put on my hot shoe it's fire the flash once even in camera off condition. after that it can not be fired anymore. once i take the flash and put it on hot shoe again, it's fire once again when the center spot get touch.

hikz.... am i get the defective camera from sony ? can i ask for new one ?
are you already asking sony about this ?
 

Latest posts

Top Bottom