1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

Help! Olympus PEN-F 38mm STUCK on adapter!

Discussion in 'Adapted Lenses' started by José Ramos, Mar 26, 2013.

  1. José Ramos

    José Ramos New to TalkEmount

    1
    Mar 26, 2013
    Hello there.

    This is my first post on the Talknexforum (I'm a Sony Alpha user), and unfortunately it's not for a good reason.

    I bought a used Olympus 38mm PEN-F f1.8 for my Sony NEX5. I also ordered an ebay adapter. I was going to buy a cheap adapter from Amazon, but was warned that it didn't have a necessary aperture pin so that I would be able to change aperture without having to push the aperture button in the lens. As such, I went for a generic chinese adapter from ebay.

    I received both the lens and the adapter today. To my surprise, as soon as I tried to attach the lens it got immediatly stuck in the adapter! I didn't exert that much force when it got stuck, and I was barely starting to rotate it in the adapter.

    Since I couldn't remove it, I tried to see if it would attach any further. I wouldn't mind that much to have the lens stuck in the adapter, since I won't use it for anything else. It moved a tiny bit, but I couldn't fully attach it.

    Right now I can't either try to attach if further or remove it! I'm not a weak guy, and I already applied a LOT of strength to remove the lens, and it won't move.

    I'm attaching two quick pictures I made of the bottom of the lens on the adapter. In the second picture you can see that the lens is rotated a bit further, which happened after I forced it into attaching, instead of removal.

    [​IMG]

    [​IMG]

    Looking forward to hear from you. Sorry if my english isn't that good, but it's not my native language.