Help needed !! Add-on hotshoe doesn't seem to work on 5N

Discussion in 'Accessories' started by nianys, Sep 14, 2012.

  1. nianys

    nianys TalkEmount All-Pro

    Aug 23, 2012
    France
    I just got my add-on hotshoe for my NEX 5N, that goes into the accessory port and is screwed in (neat little screw and screwdrivers are included). My SB-600 mounts on and locks in just fine, except then the flash is not fired ny the camera (everything in manual mode, which worked like a charm with everything I ever tried it on, including the tiny Oly ZX-1).

    Any idea as to why it doesn't work ??

    Thanks a lot.
     
  2. Phoenix

    Phoenix TalkEmount Top Veteran

    859
    Aug 25, 2011
    Melbourne, Australia
    Phoenix Gonzales
    Is the flash setting switched on in the camera?
     
  3. nianys

    nianys TalkEmount All-Pro

    Aug 23, 2012
    France
    Nope, nothing is showing :( If I manually depress the flash it goes off, but firing the shutter don't work. It's acting like it has no coupling with the camera whatsoever.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.