Do I need to update my firmware (Nex 6)?

Discussion in 'Sony Alpha E-Mount Cameras' started by dshin525, Oct 23, 2013.

  1. dshin525

    dshin525 TalkEmount Regular

    Jan 4, 2013
    I noticed that a new firmware is available for the Nex 6. If I read the description correctly, the update is for various e-mount lenses. I don't use any e-mounts…only legacy MF glass.
    Is there any benefit in updating the firmware? THanks.
  2. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    Real Name:
    There may be other minor bug fixes that Sony threw in with the firmware update. But we'll never know. So...

    FWIW, I've never had any trouble (knock wood) with any camera or lens firmware update.
  3. Gandalf

    Gandalf TalkEmount Regular

    Sep 5, 2013
    I also use legacy glass almost all the time. However, I also have several of the Sony apps installed on my NEX-6, so I elected to update the firmware to v1.02 just in case it made a difference. I had no problems doing the update and none since then.
  4. eight_eight

    eight_eight New to TalkEmount

    Jul 13, 2013
    does updating reset your setup/button preferences?
  5. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    Real Name:
  6. imperialv

    imperialv New to TalkEmount

    Nov 10, 2013
    I tried updating my nex-6, i accidentally removed the usb connection without waiting the unit to turn on (after clicking the finish button). My problem now is it wont turn on and there is a red light that is flashing besides the battery door. Did I bricked my camera?

    Sent from my iPad using TalkEmount
  7. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    Real Name:
    Have you tried A) removing and replacing the battery, and/or B) trying to run the firmware update again?
  8. NickCyprus

    NickCyprus Super Moderator

    Oct 11, 2012
    Real Name:
    Just got my Nex-6 (super exhited btw!!!).
    Mine came with the v1.01 installed.

    I've read many threads where some say that the v1.02 firmware update basically only adds faster AF for some e-mount lenses, where others claim it offers few more updates (such as better AWB etc). So I'm confused...

    I only use legacy adapted lenses - should I upgrade the firmware of don't bother???
  9. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    Real Name:
    Unless I have some specific and credible information about some problem with a particular firmware update, I always run them. For obvious reasons (fixing something they missed in the original firmware) manufacturers don't always list all of the things included in an update. They would prefer you to think that they're just providing it to add swell new features.

    But I also follow the instructions very carefully. I suspect most "bricking" happens because someone does something like unplugging the camera before the update finishes running, or trying to install firmware for the wrong camera/OS etc.
    • Like Like x 1
  10. CDG

    CDG TalkEmount Regular

    Dec 15, 2013
    Racine, WI
    Speaking from non camera experience, try plugging the camera in again and see if the update will continue.

    Good luck.

    Sent from my iPad using Tapatalk
  11. nex6rich

    nex6rich New to TalkEmount

    Feb 10, 2014
    I've got a prompt telling me I need to update the firmware to 1.02 so I can install the remote android app but on the sony website it says:

    The latest version of the firmware update is compatible with most commonly used versions of Microsoft Windows:
    Windows® XP* SP3
    Windows® Vista** SP2
    Windows® 7 SP1
    Windows® 8
    * 64-bit and Starter editions are not supported.

    I'm reading that as XP 64bit due to the '*' but looking for confirmation, I have W7 64bit on my computers, don't want to brick my camera if I try to update the firmware!


  12. José De Bardi

    José De Bardi Assistant in Virtue

    Aug 31, 2013
    Dorset, UK
    Real Name:
    The * is clearly only relevant to Win XP...

    Sent from my iPhone using Tapatalk