1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

Canon EF to E-Mount Metabones adaptor not Autofocusing.

Discussion in 'Adapted Lenses' started by triton3k, Nov 3, 2014.

  1. triton3k

    triton3k TalkEmount Regular

    25
    Oct 10, 2014
    The Bronx, New York
    Dennis A.K.A. Denn_Ice
    So when I first got my Metabones adaptor to mount my canon EF lens to my A7 I was able to autofocus but as of late when I go to switch from Manual focus to autofocus it wont switch and tells me this option is not available and to just switch from MF to AF on the actual lens which is how I have it but still nothing. I've tried removing the battery, taking the adaptor off, the lens off the adaptor, power off and power back on and still no AF. Focus mode just stays on manual focus. Its been tripping me out.
     
  2. triton3k

    triton3k TalkEmount Regular

    25
    Oct 10, 2014
    The Bronx, New York
    Dennis A.K.A. Denn_Ice
    anybody????
     
  3. mcvu

    mcvu TalkEmount Regular

    90
    Sep 24, 2014
    Bay Area, CA
    Minh
    I have Metabones III and haven't hit same issue with my A7r.
    Have you updated your A7 to latest firmware recently? if you did, that might also be the cause. I updated my A7r and it still work fine with the adapter.

    Make sure camera is in AF mode. I assigned AF/MF Toggle to the AF/MF switch/button.
    Try to clean electrical contacts on adapter. camera & lenses. Make sure there's no bent pin on camera.
    Try a different Canon AF lens.

    Try switching the adapter to Advanced mode and back to Green Mode see if it helps.
    http://www.metabones.com/article/of/green-power-save-mode

    If still does not work, you might have to send the adapter in for repair.
     
  4. triton3k

    triton3k TalkEmount Regular

    25
    Oct 10, 2014
    The Bronx, New York
    Dennis A.K.A. Denn_Ice
    ^thanks so much for the reply back.

    I actually did the latest firmware update which i even thought may have caused the issue. I'm gonna do what you outlined above and see if any of that works. I dont mind to manually focus but at times for stationary objects I try to autofocus despite of how slow it is.
     
  5. triton3k

    triton3k TalkEmount Regular

    25
    Oct 10, 2014
    The Bronx, New York
    Dennis A.K.A. Denn_Ice
    tried what MCVU mentioned and still nothing. I give up. :confused: