A7(R) firmware update

Discussion in 'Sony Alpha E-Mount Cameras' started by addieleman, Mar 19, 2014.

  1. addieleman

    addieleman Passionate amateur

    Nov 13, 2012
    Real Name:
    Ad Dieleman
    Just downloaded and installed the new firmware V1.02 on my A7. Some posts on dpreview indicated there were no real problems; one guy had to do 3 attempts to finally get his camera working again, so having seen that I picked up the download at Sony's Australian site, not being available yet on the Dutch site yet (as of 11.40 local time it is; noooo, I'm not an impatient person :)). Effortless install, I made sure to exactly follow the instructions. Startup seems faster indeed, and I suddenly got a message that I could upload pictures via WiFi to my PC, which I never managed to do before :confused:. Nice! Wednesday is my midweek day off, so I'll surely exercise the camera more today :).
    • Like Like x 6
  2. Deadbear77

    Deadbear77 TalkEmount Hall of Famer

    Sep 14, 2012
    Northeast Ohio
    Real Name:
    So what's with the improved image quality?
  3. addieleman

    addieleman Passionate amateur

    Nov 13, 2012
    Real Name:
    Ad Dieleman
    Dunno. Raw file size is the same as before, so still compressed I guess, and I don't bother with jpegs. I'll leave it to Thom Hogan to figure out if there's anything new with raws or jpegs, not interested enough right now.
  4. WoodWorks

    WoodWorks Super Moderator

    Dec 12, 2012
    Ashland, OR, USA
    Real Name:
    My firmware update went without a hitch. Startup is now somewhat faster, but it's certainly still not instantaneous. Image quality improvements? TBD. But I'm not agog with anticipation. For me the image quality already was pretty damn great.
  5. John D.

    John D. TalkEmount Regular

    Oct 7, 2013
    I updated this AM before heading out - and it went perfectly... The upload does take a while (I guess about 10 minutes, but I didn't time it as I was sipping my morning coffee and cruising this forum reading new threads;) ).. Anyway, on my A7R, the start-up is definitely faster. While out shooting this AM, I didn't notice any new features "smacking me in the face" or anything - but, I really wasn't trying to discover them..?

    I'll play around later with the A7r and watch this thread to see what folks discover.

    - John
  6. tbyork2014

    tbyork2014 TalkEmount Regular

    Jan 11, 2014
    The startup indeed is much faster than before following the update. I thought the 24-70/4 is focusing a bit faster as well. Not sure what other people think. I've shot at ISO 3200 and 6400 before and after updating in order to compare IQ, and I cannot say there is noticeable difference between the 2 firmware versions (using NR set to off, low or normal). So not sure what that is all about.