1. Reminder: Please use our affiliate links for holiday shopping!

A7 AF tracking: No little squares like A6000?

Discussion in 'Sony Alpha E-Mount Cameras' started by metalmania, Jul 11, 2015.

  1. metalmania

    metalmania TalkEmount Regular

    122
    Dec 3, 2014
    USA
    Sorry if this was asked before, I didn't find the answer anywhere. I used to use Flex point AF-S only on A7. Now I am trying the AF tracking. When do AF tracking in A7, does it show a single frame in green or multiple little squares? I did google and strangely in GaryFong's video I saw some little squares like in A6000 tracking but on an A7 body.

    I use AF-C, wide focus area and lock on with shutter on my A7. With FE 55/1.8, it shows a single frame on the object and track it. Is that right? Where are those little squares? Also, if lock-on is set to "On" instead of "with shutter", there is no frame showing and pressing the center button pops up a message saying that the function is not available for AF-C, why is that, I don't understand.

    Please help. Thanks!
     
  2. storyteller

    storyteller TalkEmount Veteran

    322
    Sep 25, 2011
    As an A7 owner let me break the news to you that the A7 does not have the AF it should have. There are no little squares and the tracking is slow. Sadly the A7II uses the same sensor (and it seems the same processor) so Sony could but won't upgrade the firmware to enable that. I'm not sure why you're having trouble with lock-on & C-AF. I'll have to check my cameras. I always use the "with shutter" option when using lock-on AF.
     
    • Appreciate Appreciate x 1
  3. davect01

    davect01 Super Moderator

    Aug 20, 2011
    Fountain Hills, AZ
    Dave
    Ya, the A7's are excellent stills cameras, but fast moving targets are not the ideal subjects.

    It is not until the most recent model, the A7R II that the model finally has the AF capacity that it should have had all along.
     
    • Agree Agree x 1
    • Appreciate Appreciate x 1
  4. metalmania

    metalmania TalkEmount Regular

    122
    Dec 3, 2014
    USA
    Thank you guys! With "lock-on with shutter", I could do tracking slowly. :) As for the center button, I rechecked the custom setting, found that I assigned it to "Eye AF". That means "Eye AF" is not available in AF-C mode, not lock-on.
     
    • Agree Agree x 1