Manual Flash problems Godox TT560

Discussion in 'Accessories' started by Orange, Jan 31, 2013.

  1. Orange

    Orange TalkEmount Veteran

    Joined:
    Jan 4, 2013
    Messages:
    203
    Location:
    England
    Real Name:
    It's not Orange!
    Hi guys.
    Advertisement

    Right, my GODOX TT560 flash arrived today, new batteries in. Turns on fine.
    It will not fire when release the shutter. Am I missing something REALLY obvious here?
    NEX-6 mode dial set to M, flash mode to "fill".

    Tried different modes but IT WILL NOT FIRE AND I AM GOING CRAZY ! ! ! lol!!

    Cheers for any words of wisdom ;)
     
  2. Orange

    Orange TalkEmount Veteran

    Joined:
    Jan 4, 2013
    Messages:
    203
    Location:
    England
    Real Name:
    It's not Orange!
    Is there anybody out there willing to help a slowly withering Orange??!! LOL!
    I think it may well be faulty so gonna just send it back to the seller.
    :)
     
  3. Chuck Lawson

    Chuck Lawson TalkEmount Regular

    Joined:
    Nov 23, 2012
    Messages:
    140
    Location:
    Dallas area
    I don't know the Godox flash, but have you tried cycling through the various flash modes? My NEX 6 in manual (or ap or sp; never tried any of the auto modes) / fill flash will fire any flash I've tried with it as long as the flash was set to manual, so you should be fine there.

    Failing that, you might see if you can find a friend or neighbor with another type of camera (with a normal hotshoe) to try it on theirs just to double-check that it's defective.
     
  4. Arnufle

    Arnufle New to TalkEmount

    Joined:
    Mar 7, 2014
    Messages:
    1
    Hi,

    I am having the same problem with my nex6. Have you managed to fix it?

    Thanks for the help!
     

Share This Page